Информационно-образовательный портал для учителя информатики и ИКТ     вход :: регистрация
   

Информатика и информационно-коммуникационные технологии в школе

 
   

   17.11.2018г.

Добрый день!  

Разделы портала
 
  Планы, конспекты, презентации, методические находки, дидактический материал к уроку
 
  Настройка и использование школьной компьютерной сети
 
  Краткий теоретический материал, который можно применять на уроке...
 
  Разные полезности, программы, инструкции, советы...
 
  Как сохранить здоровье на уроках информатики
 
  Примерные экзаменационные билеты и ответы
 
  Программы для скачивания...
 
  Правила для пользователей портала
 
  Компьютерное тестирование знаний. Наш проект. Cправочное online руководство по программе
 
 
Сервисы портала
все новости...
поиск по статьям сайта...
вопросы, обсуждения, решаем проблемы вместе ...
отзывы, замечания, предложения...
проверить свои знания, пройдя тесты в режиме online...
образовательные сайты, друзья портала...
для связи с администратором портала
 
Внимание! Опрос!

ЕГЭ по информатике - ... ?

очень сложный
сложный
нормальный
лёгкий
не знаю


результаты

____________________

  Полная или частичная перепечатка каким бы то ни было способом материалов данного сайта допускается только с письменного согласия автора.
  При цитировании или ином использовании материалов ссылка на портал www.klyaksa.net обязательна.

____________________
 
Наши проекты:

MyTestX - лего и удобно

 
 
Компьютер + Здоровье!
Примерный комплекс упражнений для глаз:
Закрыть глаза, сильно напрягая глазные мышцы, на счет 1-4, затем раскрыть глаза, расслабить мышцы глаз, посмотреть вдаль на счет 1-6. Повторить 4-5 раз.

Реклама:


 


Rambler's Top100

Рейтинг@Mail.ru
Яндекс цитирования
 
 

Начало » Конспекты школьника » kumir » Вложенные циклы и условия

Вложенные циклы и условия

Рассмотрим следующую задачу: Робот стоит слева от лабиринта, у которого внизу сплошная стена, а вверху есть несколько коридоров (их длина и количество не известно). Необходимо закрасить все клетки этого лабиринта.


Сначала опишем, что нужно сделать Роботу, на естественном языке. Робот должен двигаться по лабиринту влево пока снизу стена и закрашивать клетки. Для каждой клетки он должен проверить, если есть коридор вверх, необходимо подняться по нему пока сверху свободно и закрасить пройденные клетки, поднявшись вверх, нужно вернуться вниз до стены.

Теперь, когда понятно что необходимо делать, запишем алгоритм на КуМире.

использовать Робот
алг пример
нач
. вправо
. нц пока снизу стена
. . закрасить
. . если сверху свободно
. . . то
. . . . нц пока сверху свободно
. . . . . вверх; закрасить
. . . . кц
. . . . нц пока снизу свободно
. . . . . вниз
. . . . кц
. . все
. . вправо
. кц
кон

После выполнения алгоритма получим:


Изучите этот алгоритм, выполните его по шагам. По отступам хорошо видно, какие части алгоритма в какие вложены.

Блок-схема данного алгоритма может быть такой:


Оглавление

 

 

 

 

 

 

 

 

 

 

[Добавить в избранное]

 
Рекомендуем:

MyTest

Компьютерное тестирование знаний учащихся, сертификация и аттестация сотрудников.
Деcять типов заданий, локальное и сетевое тестирование...
 
Узнать больше и скачать программу MyTestXPro...
 
Обсудить на форуме и принять участие в создании банка тестов...
 
Новая группа ВКонтакте:
vk.com/MyTestXPro



Рекомендуем:


Учебник информатики (ФГОС, углубленный уровень) К.Ю. Полякова

Купить на Ozon.ru:


 
Реклама:
 

Разместите нашу кнопку

на своем сайте...
Инструкция


 
 

 
Реклама:
 
 


↑    

Дизайн, программирование и идея сайта Клякс@.net -bas- © 2004-2018г.

    ↑